在Xcode加入iPad後無法顯示綠燈

views

因為Xcode 4.2只支援到iOS5.0 然後我拿到的iPad好死不死是5.1
但Xcode 4.3需要Lion版本的mac OS 又聽說和Unity的bug一堆 基於不想花錢升級去做不確定的考量下 找了幾個小時終於找到“使用Xcode 4.2又可以支援到iOS 5.1解決方法”

主要的方式就是將Xcode 4.3(不必安裝)支援iOs5.1的部份copy到你所安裝的Xcode 4.2版本內

下載了Xcode4.3後(按此下載Xcode 4.3) 按右鍵進入Xcode4.3的資料夾內容 然後作以下動作

  • 複製Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/5.1 (9B176) 到你的Xcode 4.2  Developer/Platformes/iPhoneOS.platform/DeviceSupport
  • 複製Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS5.1.sdk 到你的Xcode 4.2 Developer/Platformes/iPhoneOS.platform/Developer/SDKs
  • 複製Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator5.1.sdk 到你的Xcode 4.2 Developer/Platformes/iPhoneSimulator.platform/Developer/SDKs/
  • 複製version.plist 到你的Xcode 4.2各相對應的資料夾

 

This entry was posted in iOS Development and tagged by Mr.M. Bookmark the permalink.


Leave a Reply

Your email address will not be published. Required fields are marked *